const regex = /^\d{4}-[a-z]{4}-\d{5}$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{4}-[a-z]{4}-\\d{5}$', 'i')
const str = `1234-abcd-12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}