$re = '/(?:\[member=)([0-9]+)](?:.+?\[\/member])/mi';
$str = '[member=6024]Heron M.O.B.[/member]
[member=44]DAVE[/member]
[MEMBER=44]DAVE[/MEMBER]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);