# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*|\"(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])*\")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])"
test_str = ("List of Valid Email Addresses\n\n"
"email@example.com\n"
"firstname.lastname@example.com\n"
"email@subdomain.example.com\n"
"firstname+lastname@example.com\n"
"email@123.123.123.123\n"
"email@[123.123.123.123]\n"
"\"email\"@example.com\n"
"1234567890@example.com\n"
"email@example-one.com\n"
"_______@example.com\n"
"email@example.name\n"
"email@example.museum\n"
"email@example.co.jp\n"
"firstname-lastname@example.com\n\n"
"List of Strange Valid Email Addresses\n\n"
"much.â€more\\ unusualâ€@example.com\n"
"very.unusual.â€@â€.unusual.com@example.com\n"
"very.â€(),:;<>[]â€.VERY.â€very@\\\\ \"veryâ€.unusual@strange.example.com\n\n"
"List of Invalid Email Addresses\n\n"
"plainaddress\n"
"#@%^%#$@#$@#.com\n"
"@example.com\n"
"Joe Smith <email@example.com>\n"
"email.example.com\n"
"email@example@example.com\n"
".email@example.com\n"
"email.@example.com\n"
"email..email@example.com\n"
"ã‚ã„ã†ãˆãŠ@example.com\n"
"email@example.com (Joe Smith)\n"
"email@example\n"
"email@-example.com\n"
"email@example.web\n"
"email@111.222.333.44444\n"
"email@example..com\n"
"Abc..123@example.com\n\n"
"List of Strange Invalid Email Addresses\n\n"
"â€(),:;<>[\\]@example.com\n"
"justâ€notâ€right@example.com\n"
"this\\ is\"really\"not\\allowed@example.com\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.