$re = '/\b\d+/m';
$str = 'he will be 60 years old today
she turns 79yo today this afternoon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);