$re = '/(?<!\$\{)\bcar\b(?!})/m';
$str = 'hey this i need to replace car ${car}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);