import Foundation
let pattern = #"^(?<name1>[^>\n]*?[a-z]) (?<year1>\d{4})-(?<date1>\d\d-\d\d) ?(v\d+)?(?<rest1>[^>\n]*?(?= >|$))(?: > (?<name2>[^>\n]*?[a-z]) (?<year2>\d{4})-(?<date2>\d\d-\d\d) ?(v\d+)?)?(?<rest2>[^>\n]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Using regex to identify two different sets of data with multiple parts
I have some file folders that I want to use reg expressions to "cut up" sections so I can reformat them. This is their general pattern:
* 2 Cold Scorpio 1998-04-13 v1 > Mick Foley 1997-09-22 v2 \[Cactus Jack\] - Whole Lotta Groove {Production}
* 2 Cold Scorpio 1998-11-08 v2 > JOB Squad 1998-11-08 v1 - Armed & Rambunctious {Production}
* 2 Cold Scorpio 1998-11-15 v3 > Al Snow 1998-10-17 v2 - Scurry v1.2 {Production}
* Acolytes, The 1998-11-21 v1 > Kurrgan 1997-12-08 v2 - Interrogation
* Acolytes, The 1999-01-02 v2 > Ministry Of Darkness, The 1999-02-13 - Follower
* Acolytes, The 1999-03-22 v3 > Undertaker, The 1995-11-19 v2 - Graveyard Symphony v3
* Acolytes, The 1999-10-18 v4 > Steve Williams 1999-03-21
* Acolytes, The 1999-10-31 v5 - T-Rex {Production}
* Adrian Adonis 1985-09-28 > Jimmy Hart 1985-03-31 - Eat Your Heart Out, Rick Springfield
* Adrian Adonis 1986-04-05 - You're So Vain {Mainstream}
* Aja Kong 1995-12-11 \[Kwang\] > Savio Vega 1994-01-30 v1 - Kwang Theme v1
* Akio 2003-11-20 v1 > Tajiri 2003-08-14 - Green Mist
* Al Snow 1996-02-24 v1 \[Avatar\] > Orient Express 1990-03-03 - Orient Express Theme
* Al Snow 1996-04-15 v2 \[Leif Cassidy\] > Rockers, The 1988-06-18 - Rockin Rockers – Rock Out v1
* Al Snow 1998-11-08 v3 > JOB Squad 1998-11-08 v1 - Armed & Rambunctious {Production}
* Al Snow 1999-11-04 v1 > Mick Foley 1999-01-25 v2 - Wreck v2
* Al Snow 2000-02-28 v1 > Head Cheese 2000-02-28 - Head Cheese
Before I was able to use the following expression to grab info when it was just a single portion:
(?<name>.*?[a-z]) (?<year>\d{4})-(?<date>\d\d-\d\d( v\d+)?) - (?<rest>.*)
However, the second set throws a monkey wrench in for those with >'s. I tried just duplicating the expression a second time like this:
(?<name>.*?[a-z]) (?<year>\d{4})-(?<date>\d\d-\d\d) (v\d+)? > (?<name>.*?[a-z]) (?<year>\d{4})-(?<date>\d\d-\d\d) (v\d+)? (?<rest>.*)
However, it's saying "A subpattern name must be unique". I have no idea how to fix this. Can anyone help?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)