re = /(?<=user=)(.+?)(?=;)/m
str = 'user=djdjdjjdjdjdj; user=jdjdjdjdjdj;
user=djdjdjjdjdjdj;user=jdjdjdjdjdj;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end