re = /http:\/\/(?!particular\.domain\.com).+/
str = 'http://particular.domain.com/
http://google.com/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end