$re = '/abc([0-9]+)(?=(?:(?!jk|abc[0-9]).)*jk)/m';
$str = 'abc12..manycharshere...hi - abc23...manyothercharshere...jk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);