import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([\\u00C0-\\u1FFF\\u2C00-\\uD7FF]+[^a-z\\u00C0-\\u1FFF\\u2C00-\\uD7FF]*)+) [a-z]+[^\\u00C0-\\u1FFF\\u2C00-\\uD7FF]*$";
final String string = "Шедевры православной музыки - 20 золотых православных песен";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}