#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Match all movie titles containing a word end in 'tes'"
Local $sString = "Enemy at the Gates" & @CRLF & _
"First Love, Last Rites" & @CRLF & _
"BrĂ¼no" & @CRLF & _
"30 Minutes or Less" & @CRLF & _
"The Ice Pirates" & @CRLF & _
"The Mighty Macs" & @CRLF & _
"Bridget Jones: The Edge of Reason" & @CRLF & _
"Blood Diamond" & @CRLF & _
"50 First Dates" & @CRLF & _
"The Greatest Game Ever Played" & @CRLF & _
"The Pirates! Band of Misfits" & @CRLF & _
"The World's Fastest Indian" & @CRLF & _
"Van Wilder: Party Liaison" & @CRLF & _
"200 Cigarettes" & @CRLF & _
"Midnight in Paris" & @CRLF & _
"The Greatest Story Ever Told" & @CRLF & _
"Kites" & @CRLF & _
"The Pirates Who Don't Do Anything: A VeggieTales Movie" & @CRLF & _
"Notes on a Scandal" & @CRLF & _
"Pirates of the Caribbean: The Curse of the Black Pearl" & @CRLF & _
"88 Minutes" & @CRLF & _
"The Ladykillers" & @CRLF & _
"The Greatest Movie Ever Sold" & @CRLF & _
"Pirates of the Caribbean: On Stranger Tides" & @CRLF & _
"Bangkok Dangerous" & @CRLF & _
"ATL" & @CRLF & _
"90 Minutes in Heaven" & @CRLF & _
"The Greatest Show on Earth" & @CRLF & _
"The Sweetest Thing" & @CRLF & _
"Beastmaster 2: Through the Portal of Time" & @CRLF & _
"From Dusk Till Dawn" & @CRLF & _
"The White Countess" & @CRLF & _
"Olympus Has Fallen" & @CRLF & _
"Akira" & @CRLF & _
"Bend It Like Beckham" & @CRLF & _
"The Art of Getting By" & @CRLF & _
"World's Greatest Dad" & @CRLF & _
"The Greatest" & @CRLF & _
"Irreplaceable" & @CRLF & _
"Gridiron Gang" & @CRLF & _
"20 Dates" & @CRLF & _
"Romance & Cigarettes" & @CRLF & _
"Pirates of the Caribbean: At World's End" & @CRLF & _
"Dick Tracy" & @CRLF & _
"Bathory: Countess of Blood" & @CRLF & _
"The Cure" & @CRLF & _
"15 Minutes" & @CRLF & _
"The Past is a Grotesque Animal" & @CRLF & _
"Pirates of the Caribbean: Dead Man's Chest" & @CRLF & _
"Surrogates" & @CRLF & _
"Sleep Tight"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")