$re = '/^(\+[0-9]{2})?\s*([0-9]{3})\s*([0-9]{6})$/m';
$str = '+34 958 123456
+34958123456d
de958123456e
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);