#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!\S{13})(COT|MED)[ABCD]?-?[0-9]{1,4}(([JK]+[0-9]*)|(\ DDD)?)"
Local $sString = "MED-123" & @CRLF & _
"COTA-1224" & @CRLF & _
"MED4" & @CRLF & _
"COTB-892K777" & @CRLF & _
"MED-33 DDD" & @CRLF & _
"MED-234J5678" & @CRLF & _
"COT-1111J11111111111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")