$re = '/(([^ .]+ +)*\S*\.\S+)/';
$str = 'file1.txt .project file2.jpg tricky file name.txt other tricky filenames containing áéÃőéáóó.gif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);