$re = '/(["\']) \1(*SKIP)(*FAIL)|[ ]{2}/m';
$str = 'a bc d " "l g\' \'gsf ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);