re = /(?<neg>stop)(*SKIP)(*FAIL)|(?s:.)+?(?=\Z|(?&neg))/
str = 'fdjkaljfdlstopfjdslafdj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end