$re = '/(^|\d)((?!\1)\d)\2{3}$/m';
$str = '0988523333
2961533333
1872333333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);