const regex = /(?<!-)\b(?![x|\-|\+]\s?)(may|may15)(?!\s[x|\-|\+])\b(?!-)(\s|\,)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!-)\\b(?![x|\\-|\\+]\\s?)(may|may15)(?!\\s[x|\\-|\\+])\\b(?!-)(\\s|\\,)', 'gi')
const str = `TRADED; Mar15 x May15, 5 MW Base 121,50 TL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}