package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([a-z\s]+\)`)
var str = `(dog apple text) (grape cushion cat)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}