$re = '/(?<=[\'\"])[\w\/-]+[.]{1}[a-zA-Z]{3}(?=[\'\"])/i';
$str = 'testing <img src="images/test1.jpg">
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);