re = /(?<=v=|v\/|embed\/|be\/)([^&?]+)/
str = 'https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end