#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(^\d+\.\d+\s)((?:(?!(?1)).)*)\bTEST\b(?2)"
Local $sString = "asdasdasda" & @CRLF & _
"2.1 adasdasdasdasdwvwetwevtwtv" & @CRLF & _
"wetvwetv TEST wqrqwvrqw" & @CRLF & _
"qwvrqwvqwr" & @CRLF & _
"2.2 whergtvwe" & @CRLF & _
"wetvwetvwetveatw" & @CRLF & _
"evtwet" & @CRLF & _
"2.3 eyrnenytunrunert" & @CRLF & _
"vqevrerwv TEST aevtawtvwetv" & @CRLF & _
"wetvwetv TEST wqrqwvrqw" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")