$re = '/((?:.*?)two\]\[)([0-9]*)(.*)/';
$str = 'name[one][1][two][45][text]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);