package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[[\w][\w\-]*[\w]+\]$`)
var str = `[Primeiro-Exemplo]
[Segundo-Exemplo-Valido]
[3-Exemplo-Valido]
[-3-Exemplo-Valido]
[Evento-4]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}