package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)`)
var str = `-33+42*99-123+242+(2*2)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}