package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.\d+)?$`)
var str = `12
12.09`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}