re = /(?:(\w+):\/\/)?(?:(\w+)\:(\w+)@)?([^\/:]+)?(?:\:(\d*))?([^#?]+)?(?:\?([^#]+))?(?:#(.+$))/i
str = 'http://www.domain.com/page.php?queryget#idPos'
# Print the match result
str.match(re) do |match|
puts match.to_s
end