$re = '/\)(?=$)/m';
$str = '08.070.838/0001-63.offset(1)
08.070.838/0001-63.offset(1asd)
08.070.838/0001-63.offset(21311)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);