re = /\((?=\w*\d*\))/m
str = '08.070.838/0001-63.offset(1)
08.070.838/0001-63.offset(1asd)
08.070.838/0001-63.offset(21311)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end