import re
regex = re.compile(r"^([A-PR-UWYZ](([0-9](([0-9]|[A-HJKSTUW])?)?)|([A-HK-Y][0-9]([0-9]|[ABEHMNPRVWXY])?)) ?[0-9][ABD-HJLNP-UW-Z]{2})$", flags=re.MULTILINE)
test_str = ("M1 1AA\n"
"M60 1NW\n"
"CR2 6XH\n"
"DN55 1PT\n"
"W1A 1HQ\n"
"EC1A 1BB\n"
"New ones:\n"
"M11AA\n"
"M1 1AA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")