$re = '/(?=(?<![A-Z])([A-Z][a-z][A-Z][A-Z])(?![A-Z]))/m';
$str = 'AbADaDD';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;