import re
regex = re.compile(r"(?=.{30})(.{1,29})\s", flags=re.MULTILINE)
test_str = "the quick brown fox jumped over the lazy dog near the bank of the river by 123 4567 8901234 567 89012 3456 789abc 012345 67890"
subst = "$1, "
result = regex.sub(subst, test_str)
if result:
print(result)