package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:\S+\s+){0,2}my car`)
var str = `Chevy is my car and Rusty is my horse.
My car is very pretty my dog is red.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}