$re = '/<h\d.+?(?=<h\d)/s';
$str = 'Aenean lacinia bibendum <a href="/life">life</a> sed consectetur. <a href="/work">Work</a> quis risus eget urna mollis ornare <a href="/about">about</a> leo.
<h1> attribute="whatever">asiponfpweg ihnasegio</h1>asd
<p>whatever</p>
<img src=""></img>
<h3> attribute="whatever">asiponfpweg ihnasegio</h3>
<p>whatever</p>
<p>whatever</p>
<h1><span> attribute="whatever">asiponfpweg ihnasegio</span></h3>
<p>whatever</p>
<h3> attribute="whatever">asiponfpweg ihnasegio</h3>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);