const regex = /(ATTEMPT\s+TO\s+ACCESS\s+DATABASE\s+)(\S+)\s+by\s+([\w.-]+)\s+(was\s+denied)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ATTEMPT\\s+TO\\s+ACCESS\\s+DATABASE\\s+)(\\S+)\\s+by\\s+([\\w.-]+)\\s+(was\\s+denied)', 'i')
const str = `<182>Mar 27 09:38:55 4.3.2.1 [5439570:00311-46004] 03/11/2015 14:13:05 ATTEMPT TO ACCESS DATABASE mail/abc.nsf by USER was denied`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}