$re = '/<\/*\w+>/';
$str = 'Questo รจ un testo con dei <tag>di apertura</tag> e di <altro>chiusura</altro>. tasto testone
teesto teeeeesto tsto tasto taaaaaaasto
Altro testo con problema differente';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);