import re
regex = re.compile(r"""
<\s*meta\s
# using lookahead to capture type to $1
(?=[^>]*?
\b(?:name|property|http-equiv)\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
)
# capture the content to $2
[^>]*?\bcontent\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
[^>]*>
""", flags=re.IGNORECASE | re.VERBOSE)
test_str = ("<meta content = foo name = bar />\n"
"<meta name= bar sdf content= foo >\n"
"<meta content=\"name\" name=\"author\">\n"
"<meta name =\"keywords\" content = \" php documentation \">\n"
"<meta name= \"DESCRIPTION\" content=\" a php manual \">\n"
"<meta name=\"geo.position\" content=\"49.33;-86.59 \">\n"
"<meta content=' 49.33;-86.59' name = geo.position >\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")