re = /^(?=.*[A-Z])(?=.*(?:\d|-))(?!.*(.).*\1)[a-zA-Z]{2}.{4,}[a-zA-Z]{2}$/m
str = 'abcd1Wer
asdpoiuyr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end