import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ ]*List of \\d+ base pairs([\\s\\S]*?)(?=\\*{5,})";
final String string = " bla bla bla \n"
+ " bla some on wanted text....\n\n"
+ "****************************************************************************\n"
+ "List of 12 base pairs\n"
+ " nt1 nt2 bp name Saenger LW DSSR\n"
+ " 1 Q.C0 Q.G22 C-G WC 19-XIX cWW cW-W\n"
+ " 2 Q.C1 Q.G21 C-G WC 19-XIX cWW cW-W\n"
+ " 3 Q.U2 Q.A20 U-A WC 20-XX cWW cW-W\n\n"
+ "****************************************************************************\n"
+ "another unwanted text ...\n"
+ "another unwanted text ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}