package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/scope(?:\/\d+)*$`)
var str = `/scope
/scope/1/12
/scope/1/12/123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}