import re
regex = re.compile(r"(?=Sent from my iPhone)(.*?)(?=<img src)", flags=re.DOTALL)
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Sagittis orci a scelerisque purus semper eget duis. Senectus et netus et malesuada fames ac turpis. Libero volutpat sed cras ornare. Tempus egestas sed sed risus pretium. Elementum nisi quis eleifend quam adipiscing vitae proin sagittis. Facilisis volutpat est velit egestas dui. In egestas erat imperdiet sed euismod nisi porta lorem. Cursus metus aliquam eleifend mi in nulla posuere sollicitudin aliquam. Augue interdum velit euismod in pellentesque massa placerat duis. Varius vel pharetra vel turpis. Neque laoreet suspendisse interdum consectetur. Sit amet consectetur adipiscing elit pellentesque habitant morbi tristiqu928347 (*&@@(*&&%@*&^$@!@#$%^&*()\n\n"
"e senectus. Nibh tortor id aliquet lectus. Purus sit amet luctus venenatis. Quis risus sed vulputate odio ut enim blandit. Ut morbi tincidunt augue interdum velit euismod in pellentesque massa. Malesuada pellentesque elit eget gravida. Nec nam aliquam sem et tortor consequat id porta nibh. Fames ac turpis egestas maecenas pharetra convallis posuere morbi.[]{}]//\n\n"
"Sent from my iPhone\n\n"
"Egestas sed tempus urna et pharetra pharetra massa massa. Placerat vestibulum lectus mauris ultrices eros in cursus. Vulputate odio ut enim blandit volutpat maecenas volutpat blandit. Gravida quis blandit turpis cursus in hac habitasse platea. Aliquam sem fringilla ut morbi tincidunt augue interdum velit euismod. Massa enim nec dui nunc mattis enim. Bibendum at varius vel pharetra vel turpis nunc eget. Nec tincidunt praesent semper feugiat. Vestibulum lectus mauris ultrices eros. \n\n"
"-----Original Message-----\n"
"<[] <img \n"
"Vulputate eu scelerisque felis imperdiet. Commodo viverra maecenas accumsan lacus vel facilisis volutpat est. Pharetra diam sit amet nisl suscipit adipiscing. Laoreet id donec ultrices tincidunt arcu non sodales neque. Vitae tempus quam pellentesque nec nam aliquam sem. Volutpat commodo sed egestas egestas fringilla phasellus faucibus scelerisque. Leo urna molestie at elementum eu facilisis sed. Enim diam vulputate ut pharetra sit.\n\n\n\n"
"-------\n\n"
"23409872 349 928374912874-9177*^(*&^@#*&@^*&%$&^%@_)(*&^% $#@!\n\n"
"<img src=\"/uploads/default/original/1X/5a6c91d63ca4340c5ef350fba4d47b1254042dfc.jpg\" width=\"375\" height=\"500\"><br/>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")