using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![^<]*>)([„]([^„“]+)[“]|[“]([^“”]+)[”]|[""]([^""]+)[""])(?![^<]*>)";
string input = @"<span class=""xyz"">Then he spoke! Finally! Reached out his hands. He wanted… the dead baby rabbit? That was what this was all about? Aiden just wanted the little thing in his hands? ""Well, just ask, right?"" Grayson tried a smile and laid the small, dead and very bloody body into his brother’s hands. ""Don’ you worry. Just ask. You can have it."" Aiden could get everything Grayson had, there was never a doubt. He even would have given him any ice cream or sweet he ever wanted. Because it was Aiden. ""Is everythin' okay now?"" Was Aiden happy now? Well…. as happy as Aiden could get. He didn’t look like it. But he never looked happy, anyway. </span>
<span class=""xyz""></span>
Then he spoke! Finally! Reached out his hands. He wanted… the dead baby rabbit? That was what this was all about? Aiden just wanted the little thing in his hands? „Well, just ask, right?“ Grayson tried a smile and laid the small, dead and very bloody body into his brother’s hands. „Don’ you worry. Just ask. You can have it.“ Aiden could get everything Grayson had, there was never a doubt. He even would have given him any ice cream or sweet he ever wanted. Because it was Aiden. „Is everythin’ okay now?“ Was Aiden happy now? Well…. as happy as Aiden could get. He didn’t look like it. But he never looked happy, anyway.
<span class=""xyz"">
Then he spoke! Finally! Reached out his hands. He wanted… the dead baby rabbit? That was what this was all about? Aiden just wanted the little thing in his hands? “Well, just ask, right?” Grayson tried a smile and laid the small, dead and very bloody body into his brother’s hands. “Don’ you worry. Just ask. You can have it.” Aiden could get everything Grayson had, there was never a doubt. He even would have given him any ice cream or sweet he ever wanted. Because it was Aiden. “Is everythin’ okay now?” Was Aiden happy now? Well…. as happy as Aiden could get. He didn’t look like it. But he never looked happy, anyway. ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}