package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Step (\d+).*`)
var str = `Step 42: 35 turns`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}