re = /^[A-Za-z0-9]*(?:\.[A-Za-z0-9]*)?$/m
str = 'abc123
abc123.def456
abc.def.
.def.abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end