# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"({})\1|[{](|\s*?[^\s{}]+?\s*?|\s*?\S+?\(.*?\)\s*?|\s*?['][^']+?[']\s*?|\s*?[\"][^\"]+?[\"]\s*?|\s*?[\"][^\"]+?[\"]\.\S+?\(.*?\)\s*?|\s*?['][^']+?[']\.\S+?\(.*?\)\s*?)(?:!(\S+?))?[}]"
test_str = ("{k} must-match\n"
"{} jhtgj {} must-match\n"
"{ } not-match \n\n"
"'\"{firstName} {lastName}\" <{email}>'\n\n"
"{0.concat(\"8a b c d e\", 6)} must-match\n"
"s df s sd{\"one fielslkein 897sd'f8'97f 89s(*Y*&Sc {}d name\".toFixed(7 , 8)} must-match\n"
"s df s sd{'one fielslkein \"897sd\"f897f 89s(*Y*&Sc {}d name'.toFixed(7 , 8)} must-match\n"
"sd{0.concat(\"8a b c d e\", 6)} must-match\n\n"
"ascdac{ \"one fieldname\" } must-match\n"
"ascdac{ \"onefi eldname\".kk(kk, \"dd\") } must-match\n"
"{onefieldname.toFixed(7 , 8)} must-match\n"
"dfgsdg { \"onefieldname\".toFixed(7 , 8)} must-match\n"
"{onefieldname: \"toFixed(7 , 8)\"} not-match\n"
"{\"onefieldname\": \"toFixed(7 , 8)\"} not-match\n"
"{ \"onefiel dname\" : \"toFixed(7 , 8)\"} not-match\n"
"{ \"onefiel dname\": 8} not-match \n\n"
"{ \"o dna\" : {onefi eldname.l(7 , 8)} } not-match\n"
"{ \"o dna\" : {\"onefi eldname\".l(7 , 8)} } match-inner\n"
"{ \"f dna\" : {\"onefi eldname\".toFixed(7 , 8) }} match-inner\n"
"{ \"f dna\" : { \"onefi eldname\".toFixed(7 , 8) }} match-inner\n"
"{ \"o dme\" : {onefieldname.toFixed(7 , 8)} } match-inner\n"
"{ \"on dname\" : { onefieldname.toFixed(7 , 8)} } match-inner\n\n"
"{ {}: \"{}\" }")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.