$re = '/-\K[a-zA-Z0-9]+\b/m';
$str = 'sh0rt-t3rm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);