$re = '~<{if \$data\.nowPage>1}>.*?</div>\R*<{/if}>~is';
$str = '
I\'m looking for a regular expression to delete htmlA. The border start from
<{if $data.nowPage>1}> to /div> 1 breakLine <{/if}>
htmlA
<{if $data.nowPage>1}>
<div class="pageArrow pageFirst"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=1"><span class="icon arrow-first"></span></a></div>
<div class="pageArrow pagePrev"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$data.nowPage-1}>"><span class="icon arrow-left"></span></a></div>
<{/if}>
I have tried
$fullHtml = readFileData($file);
preg_match("/(<{if \\\\\\$data\\.nowPage>1}>(.*?)<\\/div>)(\\s)(.+?)<{\\/if}>/si",$fullHtml,$htmlA);
//$fullHtml = preg_replace(...,\'\',$fullHtml);
but it stopped too early and why print_r($htmlA) shows 5 keys?
Array
(
[0] => <{if $data.nowPage>1}>
<div class="pageArrow pageFirst"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=1"><span class="icon arrow-first"></span></a></div>
<div class="pageArrow pagePrev"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}>
[1] => <{if $data.nowPage>1}>
<div class="pageArrow pageFirst"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=1"><span class="icon arrow-first"></span></a></div>
[2] =>
<div class="pageArrow pageFirst"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=1"><span class="icon arrow-first"></span></a>
[3] =>
[4] =>
<div class="pageArrow pagePrev"><a href="?<{if !empty($data.years)}>y=<{$data.years}>
)
fullHtml. line3 to line6.
<div class="pageContainer">
<div class="pageBox">
<{if $data.nowPage>1}>
<div class="pageArrow pageFirst"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=1"><span class="icon arrow-first"></span></a></div>
<div class="pageArrow pagePrev"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$data.nowPage-1}>"><span class="icon arrow-left"></span></a></div>
<{/if}>
<{for $i=$data.nowPage-$data.pageFit to $data.totalPage}>
<{if $data.nowPage == ($i)}>
<div class="pageBtn active"><a href="javascript:void(0);"><{$i}></a></div>
<{else if $i>($data.nowPage+$data.pageFit)}>
<div class="pageMore"><span class="icon moreIcon"></span></div>
<{break}>
<{else if $i>0}>
<{if $i==$data.nowPage-$data.pageFit && $i>1}>
<div class="pageMore"><span class="icon moreIcon"></span></div>
<{/if}>
<div class="pageBtn"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$i}>"><{$i}></a></div>
<{else}>
<{/if}>
<{/for}>
<{if $data.nowPage<$data.totalPage}>
<div class="pageArrow pageNext"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$data.nowPage+1}>"><span class="icon arrow-right"></span></a></div>
<div class="pageArrow pageLast"><a href="?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$data.totalPage}>"><span class="icon arrow-last"></span></a></div>
<{/if}>
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);