package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\D+\d{4}`)
var str = `ABCDE1234ABCD1234ABCDEF1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}