re = /^(?:\+[0-9]{2} [0-9]{3} [0-9]{3} [0-9]{3}|[0-9]{2} [0-9]{7})?$/m
str = '+48 555 666 777
22 1234567
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end