re = /(?:font-family:\h*|https?:\/\/)[^\s'";}]*(*SKIP)(*FAIL)|\bmedia\b/m
str = '#mediator .media
amedias media lorem ipsumedia ar
{ el : "https://twitter.com/intent/medias/" } Amedia
.element{ font-family: media} .media'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end